[IMP UPDATE] VideoSDK Scheduled Maintenance Period

Scheduled for Jun 21, 16:30 - 20:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 27, 2026 - 06:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 27, 2026 - 05:59 UTC

Scheduled

Dear Customer,

Please be advised that VideoSDK will undergo scheduled maintenance for approximately 4 hours to perform infrastructure upgrades and maintenance activities.

Maintenance Window

• Pacific Time (PT): Sunday, June 21, 2026 | 9:30 AM – 1:30 PM
• Eastern Time (ET): Sunday, June 21, 2026 | 12:30 PM – 4:30 PM
• Central European Time (CET): Sunday, June 21, 2026 | 6:30 PM – 10:30 PM
• UAE Time (GST): Sunday, June 21, 2026 | 8:30 PM – 12:30 AM (Mon)
• Indian Standard Time (IST): Sunday, June 21, 2026 | 10:00 PM – 2:00 AM (Mon)
• Singapore Time (SGT): Monday, June 22, 2026 | 12:30 AM – 4:30 AM
• Australian Eastern Time (AEST): Monday, June 22, 2026 | 2:30 AM – 6:30 AM

During this maintenance window, VideoSDK APIs and services may be temporarily unavailable. All services will resume immediately upon completion of the maintenance.

We appreciate your patience and understanding. If you have any questions, please contact support@videosdk.live.

Thank you,
VideoSDK Team
Posted May 26, 2026 - 09:10 UTC
This scheduled maintenance affects: Meetings, Recordings, RTMP, Interactive Live Streaming (HLS), and Dashboard.